Barebones CMS

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Client installation error: Unable to establish a connection to 'tls:...
Hi Ninja thruska,

Thanks for this super app. I was happily using it in a shared hosting account and everything was fine. Actually I was just developing my first site.

Then I decided to move to production in a VPS. I am running now under Ubuntu 16.04 and used Webmin/Virtualmin to configure most of the environment. LetsEncrypt provided the certificate, which is working fine as you can see here:

Problem is, in production I cannot make it work because client installation fails  with error "Failed to connect to the SSO server. Error: Unable to establish a connection to 'tls://'. Info: (0)". The weirdest of all is that it worked yesterday night, I configured Google, then this error began. I can't remember changing anything else...

Now the client interface only gives the error "Unable to obtain SSO server login access. Error: Unable to establish a connection to 'tls:...". The same error I get now in fresh installations.

So what could it be? I have searched all day and installed twice from the start. I have no idea what to check anymore. (I can give you root access if you want.)

Thanks for any help, this is all that keeps me from going alive now!


I recognize that error a mile away!

You need to update to the latest SSO client from GitHub, which has the latest Ultimate Web Scraper Toolkit. Your server is probably configured for TLS 1.2 only but due to a bug in PHP itself, "tls://" means "TLS 1.0 only". Upgrading to the latest client fixes the issue by making requests with "ssl://" instead, which doesn't actually mean SSL (VERY confusing if you know the difference).
Author of Barebones CMS

If you found my reply to be helpful, be sure to donate!
All funding goes toward future product development.
Thanks so much, Commander thruska! Fast and accurate! I'll explain in dumb terms so anyone as "savvy" as I am can understand.

I tried to upgrade the client but it could not connect yet. However, I changed the Apache config file mydomain.conf at /etc/apache2/sites-enabled in Ubuntu and it worked:

from: SSLProtocol all -SSLv2 -SSLv3 -TLSv1 -TLSv1.1
to:  SSLProtocol all -SSLv2 -SSLv3 -TLSv1.1 (change NOT recommended by thruska. See next post)

Once TLSv1 was accepted (and Apache restarted), it connected to the server. 

To understand a bit more about the SSL/TLS versions:

Thanks again, thruska!
I appear to have forgotten to backport the changes from a few months ago to the SSO client. The relevant issue has been fixed. The above change to the web server TLS protocol list is not recommended.
Author of Barebones CMS

If you found my reply to be helpful, be sure to donate!
All funding goes toward future product development.
I'm suddenly getting the same error as the OP. In setting up a site on a shared host, I had log-in working for at least a week as I continued setting up other db tables, uploading files (but none related in any way to sso), then all of a sudden could not log in with the message "Unable to establish connection"... I eventually deleted all sso-related login tables and files and attempted to re-install but now the client won't install with the same message "Unable to establish connection..." The server installed.
I can't figure out what has changed. Using the latest server/client software, filestamped March 25, 2020, PHP 7.2. Did I somehow change something or did my host?
Sounds like your host changed something. I don't use shared hosting as there is no control and no SSH console. My go-to is either DigitalOcean for temporary instances or OVH VPS nodes for more permanent setups.

Fortunately, a lot has changed in the client in the last few months that makes it far easier to diagnose most issues than it was previously.

The new client SetDebugCallback() function allows for installed clients to be more easily diagnosed. Unfortunately, you deleted the client, which now makes it an installation issue.

I've just added debug output handling to the installer for SendRequest() failures, so it should provide more details on what's wrong now. Please use the updated client - it will hopefully emit an error related to whatever is wrong.
Author of Barebones CMS

If you found my reply to be helpful, be sure to donate!
All funding goes toward future product development.
Thanks for response and updated code. I downloaded and am in the client install process and suddenly the problem is gone, it now connects to the server so the host changed something, I didn't need to delete...
Also thanks for hosting suggestions, I hoped to only get things going on shared host, then changing. This speeds that up

Forum Jump:

Users browsing this thread: 2 Guest(s)